Granicus Issue Notification: govDelivery Communications Cloud-US Region

Incident Report for Granicus System

Update

The remediation for the Bulletins Link overview issue remains stable, and the platform is performing as expected. We continue to closely monitor system health to ensure consistency and reliability.
Updates on this case will continue to be provided on Status.Granicus.com, for other issues or questions please contact us at Support@granicus.com.
Posted Feb 16, 2026 - 06:37 MST

Monitoring

The Bulletins Link overview issue has been permanently fixed, and data is now populating as expected. We will continue to monitor the production system to ensure sustained stability.
Posted Feb 14, 2026 - 00:42 MST
This incident affects: govDelivery - Communications (Communications Cloud).