Following implementation of the fix, our Technical Support team monitored the service for several hours and confirmed that it is stable and fully operational.
We apologize for the disruption and appreciate your patience and partnership throughout the incident. If you have further questions or require additional support, please contact Granicus Support.
Posted Jul 27, 2026 - 19:27 MDT
Monitoring
We have implemented mitigation measures to address the issue impacting govMeetings MediaManager and Peak services. Service performance has improved, and we are seeing recovery across the affected platform components. The underlying DNS-related issue has been resolved, and latency levels have returned to expected ranges.
We will continue to observe performance and provide additional updates as needed. We appreciate your patience and understanding throughout this incident.
Posted Jul 27, 2026 - 11:22 MDT
Identified
Our engineering teams have identified the source of the service degradation affecting govMeetings, MediaManager, and Peak Agenda. Mitigation measures have been implemented and we are actively working to restore full functionality.
Customers may continue to experience intermittent latency or access issues during the recovery process. We are seeing service improvements and will continue to monitor as we work toward full restoration.
We will provide another update once services have been fully restored. Thank you for your patience.
Posted Jul 27, 2026 - 10:50 MDT
Investigating
Granicus Engineering teams are currently investigating reports of elevated latency and intermittent access issues affecting portions of the govMeetings platform, including MediaManager and Peak Agenda services. Some customers may experience slow performance, connection errors, or service interruptions. Our engineering teams are actively investigating and working to restore normal service. We will provide additional updates as more information becomes available.
Product: govMeetings MediaManager & Peak
Updates on this issue will continue to be provided on status.granicus.com, for other issues or questions please contact us at Support.Granicus.com.
Thank you, Granicus Customer Support
Posted Jul 27, 2026 - 10:20 MDT
This incident affected: govMeetings - Live Video, Legislative and Agenda (MediaManager, Peak).