Granicus Issue Notification: govDelivery EngagementHQ - US & EU

Incident Report for Granicus System

Resolved

Granicus Engineering teams have completed deployment of the fix to both the US and EU regions. Access to Projects and other project‑related pages within EngagementHQ is now fully restored.

All services are operating as expected, and we will continue to monitor performance closely.
Product: govDelivery EngagementHQ

Thank you for your patience while we worked to resolve this issue.
Posted Feb 26, 2026 - 02:30 MST

Update

Granicus Engineering teams have resolved an issue that was preventing access to certain Projects and other project‑related pages within EngagementHQ, for customers in the US region. The fix has been applied, and Projects are now loading as expected.
The same fix will be deployed in the EU region during non‑business hours to minimize disruption. Until then, some EU customers may continue to experience issues loading affected pages. We will provide an update once service in the EU region is restored.
Posted Feb 25, 2026 - 06:53 MST

Identified

Granicus Engineering teams are currently investigating an issue impacting govDelivery EngagementHQ. Our teams are working on this issue as priority and further updates will be provided as soon as possible.

Product: govDelivery EngagementHQ

Updates on this issue will continue to be provided on Status.Granicus.com, for other issues or questions please contact us at Support.Granicus.com.
Posted Feb 25, 2026 - 00:00 MST
This incident affected: govDelivery - EngagementHQ (EHQ - Europe, EHQ - US).