Disruption to Granicus Support Email Service

Incident Report for Granicus System

Resolved

This incident has been resolved.
Posted Jan 23, 2026 - 01:33 MST

Monitoring

We are currently aware of a disruption to some aspects of our email service. The 3rd party email service provider is currently experiencing email service delivery issues which may impact your ability to communicate with Granicus via support@granicus.com.

We are working with the 3rd party provider to resolve the issue.
Posted Jan 22, 2026 - 19:31 MST