Granicus Issue Notification: Simpleview CRM Service Disruption

Incident Report for Granicus System

Resolved

This incident has been resolved.
Posted Feb 26, 2026 - 16:14 MST

Monitoring

We have successfully implemented a permanent fix, and all services have now been fully restored. Systems are operating as expected, and no further impact is anticipated.

Should you require additional information or continue to experience any issues, please contact our customer support team for assistance.
Posted Feb 26, 2026 - 14:48 MST

Identified

We’ve confirmed the issue is network‑related and are actively working to restore normal service. Our team is applying updates to the affected systems, and we’ll provide further updates as soon as they’re available.
Posted Feb 26, 2026 - 14:16 MST

Update

We are currently experiencing a network issue that is impacting access to all Simpleview CRM sites. Our engineering teams are actively working on this with the highest priority.

We will provide the next update here as soon as more information becomes available.
Thank you for your patience.
Posted Feb 26, 2026 - 13:22 MST

Investigating

We are currently investigating an issue impacting service for Simpleview CRMs. Our teams are working on this issue as a priority and further updates will be provided as soon as possible.
Posted Feb 26, 2026 - 12:39 MST
This incident affected: Simpleview Products (CRM, CRM Extranet).