Granicus Issue Notification: govService UK (Firmstep) - Email Delivery Delays

Incident Report for Granicus System

Resolved

This incident has been resolved.
Posted May 05, 2026 - 04:23 MDT

Monitoring

0941 GMT
The issue has been resolved, and email processing has returned to normal. Our teams will continue to monitor the system to ensure stability.
Posted May 05, 2026 - 02:41 MDT

Investigating

08:52 GMT
Some Firmstep UK customers may be experiencing delays with email delivery. Our teams are actively investigating and working to resolve the issue. We will provide a further update shortly.
Posted May 05, 2026 - 01:55 MDT
This incident affected: govService (govService U.K.).